Отписка от обновлений о новых событиях через Webhook
Для корректной работы ваших чат-ботов и мини-приложений направляйте запросы на доменplatform-api2.max.ruвместоplatform-api.max.ru. Также убедитесь, что добавили сертификат Минцифры в список доверенных
DELETE/subscriptions
Отписывает бота от получения обновлений о новых событиях через Webhook. После вызова этого метода бот перестаёт получать уведомления о новых событиях на Webhook-endpoint, и становится доступна доставка уведомлений через Long Polling
- Для повышения безопасности с 25 мая прекращается поддержка получения вебхуков по HTTP, а также самоподписных сертификатов. Рекомендуем заранее перейти на HTTPS и сертификаты от доверенных центров, в том числе сертификаты Минцифры. Чтобы обновить подписку на события, используйте POST /subscriptions
- Получение обновлений с помощью Long Polling ограничено по скорости и сроку хранения событий — этот способ не подходит для production-окружения. Рекомендуем на всех этапах работы использовать Webhook
Пример запроса:
curl -X DELETE "https://platform-api2.max.ru/subscriptions?url=https://your-domain.com/webhook" \
-H "Authorization: {access_token}"Авторизация
Передача токена через query-параметры больше не поддерживается — используйте заголовок
Authorization: <token>
Токен для вызова HTTP-запросов присваивается при создании бота — его можно найти на платформе в разделе Чат-боты. Выберите необходимого бота и нажмите ⋮ → Настройки → значок копирования справа от поля с токеном
Если вы верифицировали профиль и создали бота в мини-приложении «MAX для бизнеса», получить токен можно там же или в боте «MAX для бизнеса» с помощью команды Получить токен
Рекомендуем не разглашать токен посторонним, чтобы они не получили доступ к управлению ботом. Токен может быть отозван за нарушение Правил платформы
Параметры
Результат
true, если запрос был успешным, false — в противном случае
Коды ответов
| Код | Описание |
|---|---|
200 | Бот отписан от обновлений или запрос завершился ошибкой (причина ошибки описана в message) |
401 | Ошибка авторизации. Токен access_token указан некорректно или недействителен |
500 | Внутренняя ошибка сервера |