

Для корректной работы ваших чат-ботов и мини-приложений направляйте запросы на домен `platform-api2.max.ru` вместо `platform-api.max.ru`. Также убедитесь, что добавили сертификат Минцифры в список доверенных

Удаляет сообщения в диалоге, групповом чате или канале

 #### Ограничения 

- Бот должен быть администратором и иметь право на удаление сообщений

- Бот может удалять сообщения:

  - в диалоге — только сообщения, отправленные самим ботом

  - в групповом чате — любые сообщения

  - в канале — любые сообщения

- Можно удалять не более двух сообщений в секунду в одном диалоге, групповом чате или канале. При превышении этого лимита сообщения следует ставить в очередь или делать задержку перед удалением

#### Пример запроса:

curl -X DELETE "https://platform-api2.max.ru/messages?message_id={message_id}" \
  -H "Authorization: {access_token}"

## Авторизация

> Передача токена через query-параметры больше не поддерживается — используйте заголовок `Authorization: `

Токен для вызова HTTP-запросов присваивается при создании бота — его можно найти на [платформе](https://business.max.ru/self) в разделе **Чат-боты**. Выберите необходимого бота и нажмите **⋮** → **Настройки** → значок копирования справа от поля с токеном

Если вы верифицировали профиль и создали бота в [мини-приложении «MAX для бизнеса»](https://max.ru/business_bot?startapp), получить токен можно там же или в [боте «MAX для бизнеса»](https://max.ru/business_bot) с помощью команды **Получить токен**

Рекомендуем не разглашать токен посторонним, чтобы они не получили доступ к управлению ботом.
Токен может быть отозван за нарушение Правил платформы

## Параметры

от `1` символа

ID удаляемого сообщения

## Результат

`true`, если запрос был успешным, `false` — в противном случае
Сообщение об ошибке

## Коды ответов

| Код | Описание |
| --- | --- |
| `200` | Объект удалён или запрос завершился ошибкой (причина ошибки описана в `message`) |
| `401` | Ошибка авторизации. Токен `access_token` указан некорректно или недействителен |
| `403` | Ошибка доступа. У вас нет прав на доступ к этому ресурсу |
| `500` | Внутренняя ошибка сервера |

